"All repositories" access selection not shown


#1

I’m sure it’s a known issue, but when I install my app and select “All repositories”, after saving the radio button is not selected, so there’s no indication that the installation has access to all repositories.


#2

I don’t think it’s a known issue – thanks for reporting this, @flaviocopes :bow:. I’ll ask the team to take a look and we’ll followup here as soon as there’s any news.


#3

I saw this the other day, too. Didn’t realize it was definitely a bug, but I just wanted to echo that I also found it puzzling.

Also, in some cases it looks like images are broken in the typeahead suggest.

And though this is maybe outside the scope of discussion, something that’s frustrating about the typeahead is that I can’t always remember the name of the repo I’m looking for. I’m curious why you decided on a typeahead and not just a checklist, or why the typeahead isn’t populated with content and it’s used more as a local filter.

Thanks!


#4

Thanks for that feedback, @JoshSmith – I’ll pass it along to the team and if they’d like to share the reasoning about why the typeahead was picked over the ideas you shared, we’ll followup.

I’ll also try to reproduce the broken images you mentioned – that does sound strange. :confused:


#5

Also, in some cases it looks like images are broken in the typeahead suggest.

@JoshSmith I just tried and wasn’t able to reproduce this. Can you share a GIF with step-by-step instructions for reproducing this? Are you able to reproduce that reliably or does it happen randomly?


#6

@JoshSmith Ah, nevermind – I was able to reproduce it. Will open an internal issue :thumbsup:


#7

I’m guessing it’s something about the request being so fast that the image isn’t fully loaded yet, but it could it be some other problem.

The typeahead would be great if it worked more like the labels typeahead in an issue. Not knowing the available choices upfront means I have to think about what I’m even looking for.

The reason I think that design choice was made is due to the possible high volume of repositories that might populate the list. But if that’s the case, then it would actually further justify being able to see those repositories without typing. If I have so many repositories that it’s a burden to sideload all that data for a server, it’s probably a monumental burden for me to remember them all as a human.


#8

Thanks for sharing your thoughts again, @JoshSmith – I’ll pass them along to the team.


#9

Hey @flaviocopes and @JoshSmith :wave:. Just wanted to let you know that the team deployed some changes which should have fixed the problem with the radio button. If you can still reproduce this — please let us know. And thanks again for reporting this. :bow:


#10

Looks fixed to me. Thanks!