Data discrepancy between the GitHub UI and the GraphQL results


#1

Hello,

I was running some test queries and I noticed a difference in the results of the API and the GitHub UI

When I run the query:

query {
  viewer {
    followers(first: 30) {
      totalCount,
      edges {
        node {
          login
        }
      }
    }
  }
}

I get back:

{
  "data": {
    "viewer": {
      "followers": {
        "totalCount": 20,
        "edges": [
          {
            "node": {
              "login": "evinw"
            }
          },
          {
            "node": {
              "login": "leoj3n"
            }
          },
          {
            "node": {
              "login": "arunsingh"
            }
          },
          {
            "node": {
              "login": "jpahullo"
            }
          },
          {
            "node": {
              "login": "cusspvz"
            }
          },
          {
            "node": {
              "login": "nurortegamarsal"
            }
          },
          {
            "node": {
              "login": "garenas6"
            }
          },
          {
            "node": {
              "login": "sivsushruth"
            }
          },
          {
            "node": {
              "login": "Tysonhuang"
            }
          },
          {
            "node": {
              "login": "angusshire"
            }
          },
          {
            "node": {
              "login": "kristinaban"
            }
          },
          {
            "node": {
              "login": "danielboloc"
            }
          },
          {
            "node": {
              "login": "etdev"
            }
          },
          {
            "node": {
              "login": "danitome24"
            }
          },
          {
            "node": {
              "login": "sasha240100"
            }
          },
          {
            "node": {
              "login": "jkxyz"
            }
          },
          {
            "node": {
              "login": "ternsip"
            }
          },
          {
            "node": {
              "login": "zzZIMAWAKE"
            }
          },
          {
            "node": {
              "login": "Jue92"
            }
          },
          {
            "node": {
              "login": "JHipolito"
            }
          }
        ]
      }
    }
  }
}

But when I check my followers using the GitHub UI I only see 19. The difference is this user: Tysonhuang that seems to have been deleted. I don’t know if this is because of caching or because the data is different while in early access but I thought I’d mention it.

Thanks,
Rob


#2

Hey Robert! We’re looking into this on our side and hope to have it fixed shortly.


#3

@robertboloc This shooouuuld be fixed now… That Tysonhuang account shouldn’t be showing up anymore and your count should be correct. Mind making that query again and making sure for us? :smile:


#4

@davidcelis The count and results are correct now. Thanks :slight_smile:


#5