Repo not listed in install UI


#1

We have started testing our integration on a “real account” that has several hundred repositories in it. We have a situation where the user (who is the owner) cannot select a specific repository from the drop down selection in the UI. We can’t figure out why it’s not working but we are starting to think it might be a UI bug.

The repository itself is open source and the person who is authenticated is an owner of the entire org (and creator of the repo). When he types the name of the repository a number of matches come back but not the actual repo itself.

The name of the repo is “amp” but there are a lot of repos with this prefix (the main one happening to the “amp” but others are like “amp-project” etc). We’re thinking that it must be that the UI/backend search is constraining to 5 items in the UI but there are actually more than 5 and the search isn’t matching (for whatever reason) correctly the exact spelling of the repo.

We even tried typing the name of the org + repo (the full_name) and that doesn’t appear to work either. It appears the search algorithm is matching any character based on playing around with it from the UI.

I have a ton of detail and even a screen recording if this would help explain in further detail. This is preventing us from moving forward and a huge blocker. Any help is much appreciated!


#2

we were finally about to narrow this down and make it work by renaming the repo to something obviously unique (in this case we renamed from “amp” to “zamp”) and it worked. We then could see the repo and import it. We then renamed the repo back to original name.


#3

Hi @jhaynie, apologies for the delay. We’ve just made some changes to this area, so it should work smoother next time. Thanks!


#4

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.