vulnerabilityAlerts as a type on DependencyGraphDependency


#1

According to https://developer.github.com/v4/previews/#repository-vulnerability-alerts, the API should provide DependencyGraphDependency.vulnerabilityAlerts. However, I’m only able to grab vulnerability alerts from the repository, i.e. Repository.vulnerabilityAlerts works.

Here’s an example query:

{
    repository(owner: \"%s\", name: \"%s\")
    {
        dependencyGraphManifests(first: 100)
        {
            nodes
            {
                dependencies(first: 100)
                {
                    nodes
                    {
                        packageName
                        vulnerabilityAlerts
                    }
                }
            }
        }
    }
}

The response is "Field 'vulnerabilityAlerts' doesn't exist on type 'DependencyGraphDependency'", which seems to contradict the API specification.