Webhook suddenly does not work. Error: we couldn’t deliver this payload service timeout


#1

Jenkins uses generic webhook plugin. Everything works fine on last Friday. But on Monday, the webhook does not work. I checked web hook on github. I saw error: “We couldn’t deliver this payload service timeout”


My Payload URL is: http://serverip:8080/generic-webhook-trigger/invoke
Firewall is disabled on my Jenkins sever. I manually post the request using curl. It works fine.
GitHub has been upgraded to 2.14.7 on this weekend. Is this a bug of GitHub?


#2

It sounds like your service timed out when GitHub sent you that request. That could easily be a transitory problem, but you might want to check that any heavy lifting is done asynchronously on your side, rather than in the request cycle, if you’re seeing this consistently.

Perhaps someone from GitHub can comment what the timeout threshold is? Regardless, webhooks are currently working fine for my app, so the problem isn’t affecting (all) other integrators.


#3

Problem is solved. It’s a network problem of our enterprise github. Something like ‘forget to set up proxy’. I don’t know the details, but it’s solved now.